Sophie

Sophie

distrib > Mageia > cauldron > i586 > by-pkgid > b3ef820d0ead05765bb6c940248db073 > files > 2

erlang-p1_utils-1.0.12-2.mga7.src.rpm

%global srcname p1_utils
# Erlang packages do not provide debug subpackages
%global debug_package %{nil}


Name:       erlang-%{srcname}
Version:    1.0.12
Release:    %mkrel 2
Group:      Development/Erlang
Summary:    Erlang utility modules from ProcessOne

License:    ASL 2.0
URL:        https://github.com/processone/p1_utils/
Source0:    https://github.com/processone/p1_utils/archive/%{version}/%{srcname}-%{version}.tar.gz
Patch1:     erlang-p1_utils-0001-Don-t-use-function-from-Ejabberd.patch

BuildRequires: erlang-rebar
BuildRequires: erlang-edoc
BuildRequires: erlang-eunit

%description
p1_utils is an application containing ProcessOne modules and tools that are
leveraged in other development projects.


%prep
%autosetup -p1 -n %{srcname}-%{version}
# This file was 755 upstream, which causes an rpmlint warning. This pull request has
# been created to fix the issue upstream:
# https://github.com/processone/p1_utils/pull/4
chmod 0644 doc/style.css

# https://github.com/processone/p1_utils/pull/7
sed -i "/.*Created.*/d" src/p1_options.erl


%build
%{rebar_compile}
%{rebar_doc}


%check
%{rebar_eunit}


%install
%{erlang_install}


%files
%license LICENSE.txt
%doc CHANGELOG.md
%doc doc
%doc README.md
%{erlang_appdir}




%changelog
* Fri Sep 21 2018 wally <wally> 1.0.12-2.mga7
  (not released yet)
+ Revision: 1295004
- revert noarch change

* Thu Sep 20 2018 wally <wally> 1.0.12-1.mga7
+ Revision: 1288425
- new version 1.0.12 (Sync with Fedora)

* Thu Nov 17 2016 neoclust <neoclust> 1.0.5-1.mga6
+ Revision: 1067871
- New version 1.0.5

* Fri May 06 2016 neoclust <neoclust> 1.0.4-1.mga6
+ Revision: 1009832
- imported package erlang-p1_utils